تبلیغات

Extensions incompatible with current version
شناسه: 1663
بازدید: 162

در مورد نحوه انتخاب افزونه در وردپرس و نحوه نصب افزونه ها قبلا توضیح داده بودم، اما بعضی مواقع پس از یافتن یک افزونه که کاری که مد نظر شما است را انجام می دهد، می بینید که این افزونه با نسخه نصبی وردپرس ناسازگار است.

آیا باید افزونه های ناسازگار با نسخه فعلی را نصب کنید؟ لینک لینک لینک

همیشه تاکید می کنم که باید از به روزترین نسخه وردپرس استفاده کنید در مورد افزونه ها و قالب ها نیز همین موضوع صادق است.
در هر نسخه از وردپرس ممکن است باگ هایی به وجود بیاید که در هنگام به روزرسانی این باگ ها برطرف می شوند و در صورتی که شما از نسخه قدیمی وردپرس استفاده کنید، ممکن است این باگ ها به وب سایت شما آسیب برسانند.

افزونه های ناسازگار با نسخه فعلی

حتما شما هم وقتی که افزونه ای را انتخاب می کنید و برای نصب کردن آن به منوی افزونه ها >> افزودن می روید، برای برخی از آن ها پیغام با نگارش وردپرس شما سازگار است و برای برخی دیگر پیغام با نگارش وردپرس شما آزمایش نشده است را مشاهده خواهید کرد.

Extensions incompatible with current version 3

اینکه وردپرس از کجا می فهمد یک افزونه با نسخه فعلی تست شده یا نه و اینکه چرا باید افزونه ها باوردپرسی نصبی تست شده باشند، مواردی هستند که در ادامه بررسی خواهم کرد.

وردپرس چگونه متوجه می شود افزونه با نسخه ما سازگار نیست؟

بزرگترین منبع افزونه های وردپرس، مخزن وردپرس است. هنگام ارسال یک افزونه و ثبت آن، نویسندگان موظف اند یک فایل راهنمای افزونه و ترجمه آن را همراه با افزونه ارسال کنند.
این فایل برای ساخت صفحه معرفی افزونه در مخزن وردپرس مورد استفاده قرار می گیرد. مانند آنچه در تصویر زیر می بینید یک افزونه در مخزن وردپرس حاوی اطلاعات تعداد نصب فعال، توضیحات افزونه و آزمایش شده تا نسخه وردپرس است.

Extensions incompatible with current version 4

این فایل راهنما حاوی برچسب tested up to نیز می شود که برای نمایش اطلاعات مربوط به نسخه وردپرس آزمایش شده استفاده می شود.
با کمک این برچسب وردپرس می تواند نسخه تست شده را با نصب شده مقایسه کرده و اگر افزونه با نسخه نصبی شما بررسی نشده باشد، خطای افزونه های ناسازگار با نسخه فعلی را نمایش می دهد.
نویسندگان افزونه ها موظف اند همیشه اطلاعات را به روز نگه دارند و این به این معنی است که با هر نسخه از وردپرس، نویسندگان افزونه باید افزونه را تست و فایل های راهنما برای افزونه های خود به روز رسانی کنند.

چرا نویسندگان افزونه اطلاعات را به روز رسانی نمی کنند؟

بسیاری از نویسندگان افزونه، به هیچ وجه فایل های خود را حتی زمانی که افزونه هارا با آخرین نسخه تست می کنند، به روز رسانی نمی کنند!
این افزونه ها رایگان هستند و شما برای استفاده از آن ها هیچ پرداختی به نویسنده انجام نمی دهید. نویسندگان کمتر تمایل به روزرسانی فایل های راهنمای خود دارند و بیشتر مشغول پروژه های خود هستند. اما این به این معنی نمی باشد که افزونه کارکرد خوبی ندارد.

 آیا می تواین افزونه های ناسازگار با نسخه فعلی را نصب کرد؟

افزونه های ناسازگار با نسخه فعلی را می توانید نصب کنید و علت خطای ناسازگاری عدم آپدیت فایل راهنما توسط نویسنده افزونه می باشد.
البته پیشنهاد می شود که افزونه هایی که بیش از ۶ ماه یا حداکثر بیش از ۲ سال از آخرین به روزرسانی آن ها می گذرد را نصب نکنید، چرا که ممکن است این افزونه به صورت کامل متروکه شده باشد.

هنگام بروز خطا چه کنیم؟

اگر پس از نصب افزونه های ناسازگار با نسخه فعلی با خطایی مواجه شدید، بهتر است افزونه را در محیط های مختلف تست کنید و اگر بازهم خطا دریافت کردید، اطلاعات خطا را برای بررسی نویسنده افزونه در صفحه افزونه قرار دهید.

نکته :

هیچ وقت بدون داشتن نسخه پشتیبان اقدام به نصب افزونه حتی افزونه های سازگار با سایتتان نکنید و همیشه از قبل یک بک آپ تهیه کنید.ترجیحا افزونه های قدیمی تر را در لوکال هاست و یا وب سایت تستی بررسی کنید و پس از اینکه اطمینان حاصل کردید افزونه های ناسازگار درست کار می کنند، آن را روی وب سایت اصلی خود نیز استفاده کنید.

چرا نباید افزونه های ناسازگار با نسخه فعلی وردپرس را نصب کنیم؟
0 از 0 رای

نویسنده

مهناز حسن زاده
مهناز حسن زاده هستم ، عاشق وردپرس و درج مطالب آموزشی . امیدوارم با استفاده از مطالب آموزشی من بتوانید مشکلات خود را در زمینه های مختلف حل کنید . لطفا انتقادات و پیشنهادات خود را زیر هر مطلب بیان کنید .

تبلیغات